Vauxhall Owners Network Forum banner

engine faults

  1. Small/Medium Vauxhall Cars Area
    My astra while driving will sometimes loose power completely, the battery light comes on as well as a car with a spanner. then the engine wont fire up, doesnt make any noise when turning the key, but after a few minutes will fire up with no problems, ive had the car about 2 weeks and its done...
  2. Small/Medium Vauxhall Cars Area
    Hi, This is my first ever post so any help will be appreciated. I currently have a 59 plate Astra H with 32k miles on the clock. I bought it last winter with a full service and mot, and it hasn't been serviced since (next job on my list). Yesterday, after getting all 4 pads and discs...
  3. Large Vauxhalls
    hi recently the engine developed the above fault the car has a lack of power especially up hills and a strong smell of fuel from the exhaust. So far I have replaced the plugs ,coil pack, injectors and egr valve I have also cleaned the throttle body which was covered in black oily sludge and...
  4. Small/Medium Vauxhall Cars Area
    Hey all, I've got two issues with my 1.6L Astra Twinport. First off, the engine light has now come on constantly, I'm experiencing a loss of power and when I press the accelerator and put any strain on the engine, it judders slightly and I hear a squeaking noise. This also causes the engine...
  5. Large Vauxhalls
    hi new here hope this is in the right place I was driving home this evening and heard a clunk stopped popped the bonnet noticed my ancillary belt was not rotating,on closer inspection I noticed one of my pullies was laid on my engine under tray! I think it's an idler pulley but not sure! Any...
  6. SUV & 4WD Vauxhalls
    Hello, I have a Vauxhall Frontera which has been having a few fault issues. When the car starts up it flags up the manifold pressure sensor, and after about five minutes it flags up the speed sensor. Both of these sensors have been changed but the car keeps flagging it up. When you erase the...
Top