1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. It's been bought to our attention that certain users are spamming new and existing users with links to their own websites. This is not permitted on VxON.
    Should you receive such a message, please report this using the 'Report' link you will find at the bottom of the message.
    Those users will then be dealt with accordingly.
  3. Use The Search Function That's what It is There For!
    The chances are that the post you are about to make has already been asked so USE the search function first! You can either search JUST this forum by clicking on the search button on the top right (under the page numbers) or click on the main search button that is on the top tool bar.
    This will save you time and stop the same duplicate posts from appearing.

Zafira MOT Failed on Exhaust Emissions - Any Clues?

Discussion in 'Astra, Corsa, Zafira, Meriva, Adam, Agila, Tigra & Nova [Includes AstraVan & ComboVan] owners forum' started by Atomfun, Mar 3, 2009.

  1. Atomfun

    Atomfun Member

    Messages:
    36
    Likes Received:
    0
    Location:
    Bridgend, South Wales
    Hi guys

    My partner's 1990 VX Zafirra 1.8 Comfort Automatic (petrol) just failed the MOT on exhaust emissions.

    Can anyone give me clues to remedy this problem?

    Many thanks

    John
     
  2. MutantCav

    MutantCav Well-Known Member

    Messages:
    2,549
    Likes Received:
    0
    Location:
    Gainsborough UK
    Is it running ok? Has it been sat for a while before the MOT or done lots of short journeys?
     
  3. Atomfun

    Atomfun Member

    Messages:
    36
    Likes Received:
    0
    Location:
    Bridgend, South Wales
    Blimey! That was quick.

    She uses her car each day, 15 miles to and from work - 30 miles round trip.

    It has been going okay BUT, it sometimes stalls at lights or when stopped. This seems to be more of a problem when in the Park position! At least, that's what she tells me.

    I have used some fuel additive lately to try clean out the injectors etc as recommended by someone else.

    Sorry, forgot to say it's automatic
     
  4. BBert

    BBert Member

    Messages:
    223
    Likes Received:
    0
    Location:
    Worcester UK
    1990? Eh..

    Is the the EML light on the dash or any foul gas smells coming into the cab.

    Mine failed last year mine was the Lambda/Oxygen sensor.
     
  5. Atomfun

    Atomfun Member

    Messages:
    36
    Likes Received:
    0
    Location:
    Bridgend, South Wales
    The EML has been on & off for years! It's on more than off and been looked at by various garages without success and a few bills!

    Can't say there's any foul smells and I don't think the CAT has clapsed or blocked as it goes really well when 'wound up' :)

    I try to think of the cheapest remedies first:

    1. Petrol treatment stuff followed by a hi revving trip somewhere before taking it in for a retest.

    2. Lambda sensor - how much and is it easily changed?

    3. CAT - I shudder to think!!!

    I changed all the disks and pads just a week ago.

    Cheers
     
  6. BBert

    BBert Member

    Messages:
    223
    Likes Received:
    0
    Location:
    Worcester UK
    Lambda is £100 from vauxhall or £50ish from a motor factors. Easy to change.
     
  7. Atomfun

    Atomfun Member

    Messages:
    36
    Likes Received:
    0
    Location:
    Bridgend, South Wales
    Why does the cost of the sensor vary so much on, dare I say it, Ebay?

    Price range from £18 to £80!!

    Where is the sensor located on the Zafira?

    John
     
  8. mobileservices

    mobileservices New Member

    Messages:
    36
    Likes Received:
    0
    Location:
    biggin hill
    hi dont mess around with pattern sugar, if you have a fault like that what where the emission readings did they fail on idle or fast test CO or cat test could be some thing simple .there is no point on wasting money keep bolting bits on till youve solved the problem you may as well pay and have it diagnosed properly and it would be cheaper
     
  9. Atomfun

    Atomfun Member

    Messages:
    36
    Likes Received:
    0
    Location:
    Bridgend, South Wales
    It failed on 2nd fast idle - whatever that means!
     
  10. MutantCav

    MutantCav Well-Known Member

    Messages:
    2,549
    Likes Received:
    0
    Location:
    Gainsborough UK
    Idle issues and failing on idle ommisions are probably linked,,,do they have an idle control valve??
     

Share This Page