1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. It's been bought to our attention that certain users are spamming new and existing users with links to their own websites. This is not permitted on VxON.
    Should you receive such a message, please report this using the 'Report' link you will find at the bottom of the message.
    Those users will then be dealt with accordingly.
  3. Use The Search Function That's what It is There For!
    The chances are that the post you are about to make has already been asked so USE the search function first! You can either search JUST this forum by clicking on the search button on the top right (under the page numbers) or click on the main search button that is on the top tool bar.
    This will save you time and stop the same duplicate posts from appearing.

[Vectra C] [02-08] starting problems

Discussion in 'Cavalier, Calibra, Vectra, Signum, Sintra & Insignia owners forum' started by 1351lupin, Oct 6, 2012.

  1. 1351lupin

    1351lupin New Member

    Messages:
    17
    Likes Received:
    0
    Drives:
    Vectra SRi cdti 150
    I just bought a 2007 vectra...... It's a 1.9 cdti 150 bhp. I bought it 9 days ago, travelled 2k miles and it just was smooth and perfect........ Now its hard to start and the dash light seems to flicker while firing up...... When it fires up it works just fine but the engine check light remains on....... Any help please......
  2. andyl

    andyl Well-Known Member

    Messages:
    4,744
    Likes Received:
    577
    Location:
    bristol
    Drives:
    vectra c 2.2dti sri
  3. 1351lupin

    1351lupin New Member

    Messages:
    17
    Likes Received:
    0
    Drives:
    Vectra SRi cdti 150
    Bought it! But can you help about the starting problem? Fuel pipes maybe?
  4. andyl

    andyl Well-Known Member

    Messages:
    4,744
    Likes Received:
    577
    Location:
    bristol
    Drives:
    vectra c 2.2dti sri
    Does the check light remain lit all the time or go out after a couple of minutes.
  5. 1351lupin

    1351lupin New Member

    Messages:
    17
    Likes Received:
    0
    Drives:
    Vectra SRi cdti 150
    I need to check out....... Whem the eml light lit up i didn't drive for long.........
  6. 1351lupin

    1351lupin New Member

    Messages:
    17
    Likes Received:
    0
    Drives:
    Vectra SRi cdti 150
    What happenned yesterday freaked me out! The same problem while firing up............... after just a few metres the dash light began to flicker, power steering didn't work and the headlights flickered with the dash.............. At one point all the lights went off, power steering still not working and no controls ( indicators, wipers, windows not working either ).............. Maybe the battery has to be changed???
  7. andyl

    andyl Well-Known Member

    Messages:
    4,744
    Likes Received:
    577
    Location:
    bristol
    Drives:
    vectra c 2.2dti sri
    Sounds like the Alternator has had it.
  8. 1351lupin

    1351lupin New Member

    Messages:
    17
    Likes Received:
    0
    Drives:
    Vectra SRi cdti 150
    :confused: .................... and were talking about??
  9. andyl

    andyl Well-Known Member

    Messages:
    4,744
    Likes Received:
    577
    Location:
    bristol
    Drives:
    vectra c 2.2dti sri
    When you lose your power steering then the culprit is normally the alternator.
  10. 1351lupin

    1351lupin New Member

    Messages:
    17
    Likes Received:
    0
    Drives:
    Vectra SRi cdti 150
    Today I tried to fire it up but the battery is almost dead......... It fired up when I used the jump start.... Now I've put the battery on charge and when its fully charged ill fire it up once more and check if the alternator is producing supply....... If the alternator is the problem..maybe the brushes have to be changed or all the alternator usually goes??

Share This Page