1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. It's been bought to our attention that certain users are spamming new and existing users with links to their own websites. This is not permitted on VxON.
    Should you receive such a message, please report this using the 'Report' link you will find at the bottom of the message.
    Those users will then be dealt with accordingly.
  3. Use The Search Function That's what It is There For!
    The chances are that the post you are about to make has already been asked so USE the search function first! You can either search JUST this forum by clicking on the search button on the top right (under the page numbers) or click on the main search button that is on the top tool bar.
    This will save you time and stop the same duplicate posts from appearing.

  1. Skid

    Skid Member

    Messages:
    13
    Likes Received:
    2
    Drives:
    Zafira Elegance 1.8 Petrol (2005/A)
    All i am doing is trying to rule out problems... its called 'fault finding'... you get a code/problem and deal with it. Rule out the 'what ifs' and find out the 'what is' and act accordingly. So please - just straight and helpful answers. My car now bucks and loses power, and when i start the engine it runs idle and loses power. Then, if i try and pull away - the car doesn't move - just bucks if anything until eventually it over rev's.
  2. andyl

    andyl Well-Known Member

    Messages:
    4,664
    Likes Received:
    555
    Location:
    bristol
    Drives:
    vectra c 2.2dti sri
    Hi, What fault codes do you have.
  3. marks152

    marks152 Well-Known Member

    Messages:
    9,255
    Likes Received:
    720
    Location:
    liverpool, uk
    Right if thats how you want to play it!!!

    P0100 - MAF needs replacing - P/N 90530463 dont use cheap crap as it wont work. It has to be seimens which is a genuine part. Give VX a ring for a price

    Next code please!!
  4. marks152

    marks152 Well-Known Member

    Messages:
    9,255
    Likes Received:
    720
    Location:
    liverpool, uk
    Maybe you changed your car and never updated your status just like you forgot to tell us the list of codes your car has.

    My advice is if you want to get to the bottom of your cars problems is to stop trying to fix it yourself as its evident you dont have a clue what you are talking about and are trying to preach to the preachers. Take it to a garage!!!

    As for this quote
    What your doing is play parts darts and relying on your codes. In a real world these mean very little. Live data from the engines ECU will give you more information than a code will. Example My EGR failed and I got P0130. I didnt replace lambda - I investigated it and found the the EGR was open which in turn fed false information to the lambda which the ECU interpreted as a Lambda fault.

    Another example was a Z16XEP was showing P0115 - Temperature circuit/sensor range and P0170 fuel trim. I didnt replace the sensor, I Checked the engine running temp and found it was out of spec leading me to a stuck thermostat. Job fixed

    And another, A zafira 1.8 I was working on was showing P0340. I didnt replace the sensor. I checked its output to verify it was working which it was and then i checked the timing and found it to be 1 tooth out. The timing was reset and the code cleared and never came back.

    The list is endless!!!

    Try posting your issue on here. They are usually a helpfull bunch

    http://www.bba-reman.com/forums/Forum1-1.aspx
    Skid and smokie1010 like this.
  5. smokie1010

    smokie1010 Well-Known Member

    Messages:
    1,957
    Likes Received:
    184
    Location:
    North East England
    Drives:
    Astra H Z16XEP Twinport Dual Fuel
    I have to agree with marks152, if you tell us all the codes you are getting then it might help pinpoint the problem. As he has also said, just because a code tells you something is faulty it doesnt mean it is, there might be something else causing it and having all the codes might help finding it. I dont think its unreasonable for people to ask you for all the codes when they are trying to help you. Otherwise we are all playing guessing games and you will spend a fortune changing loads of parts possibly to find it was something which could be fixed very cheaply.
  6. Skid

    Skid Member

    Messages:
    13
    Likes Received:
    2
    Drives:
    Zafira Elegance 1.8 Petrol (2005/A)
    Ok people - i get the point. But getting sarcy about what I am asking for doesn't achieve anything. I will list the codes below and the read-out from them, if that's ok with you, and then please, just some helpful advice on my next steps. As you can imagine this gets frustrating when people act like children in a playground and others try and play grown up about things. Advice and help i asked for and if you would like to have the codes, asking politely is a nice thing to do. Saying you will use a crystal ball isn't helpful... as previously stated my car is now bucking and losing power so i would like to get this sorted and soon so i can drive the car in one piece...

    My car is a 2005 (05) ZAFIRA 'A' ELEGANCE 1.8 PETROL (already stated)
    The codes are as follows:
    0100 - MAF Sensor Circuit Insufficient Activity
    0170 - Fuel Trim Bank 1
    1525 - Throttle Body Service Required
    1550 - ???
    1555 - Electronic Variable Orifice Output

    HELPFUL AND FRIENDLY ADVICE IS ALL I NEED.
  7. Skid

    Skid Member

    Messages:
    13
    Likes Received:
    2
    Drives:
    Zafira Elegance 1.8 Petrol (2005/A)
    I have listed the codes for you
  8. Duck-Tape

    Duck-Tape Member

    Messages:
    1
    Likes Received:
    1
    Drives:
    Astra J
    Hi Skid,

    Where do you found the descriptions of your codes? I think a few are wrong and should be

    P0100 Mass Or Volume Air Flow Circuit Wrong Input
    P0170 O2 Sensor Rich/Lean Exhaust
    P1525 Limp Home Position Error
    P1550 Electronic Throttle Control Reduced Power/Forced Idle/Power Management/Engine Stop
    P1555 Throttle Position Sensor (TPS) Load Signal not Plausible with Engine Load
    Do you own a diagnistic tool? If yes which one...OPCOM, simple OBD Tool or whatever? I'm asking cause every troublecode has a so called subcode. This subcode shows more details.

    I would start with the last three codes cause i know that there's a known field remedy depending on your engine

    For Z18XE see 1391 and for Z18XE1 see 1590

    Hope it's fine to post the following links

    http://vauxhall.workshop-manuals.com/corsa-c/index.php?id=2720
    http://vauxhall.workshop-manuals.com/astra-g/index.php?id=3531
    Skid likes this.
  9. Skid

    Skid Member

    Messages:
    13
    Likes Received:
    2
    Drives:
    Zafira Elegance 1.8 Petrol (2005/A)
    I have an OBD tool, and also referred to online forums. I will look at the links, thanks for the post. I also had a diagnostic test done by a friend at Kwikfit when my car was in having a check. He noticed my EML was on and plugged it in.
  10. Fred Bassett

    Fred Bassett Well-Known Member

    Messages:
    4,770
    Likes Received:
    934
    Location:
    Hinckley
    Drives:
    2008 astra estate 1.7 cdti life
    The experts on this site give their advice and help free of charge and are happy to give some of their time to the site , however you haven't gone about asking for the help you need in a good way upsetting many people on here who could have helped . Treat people on here with respect .

Share This Page