1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. It's been bought to our attention that certain users are spamming new and existing users with links to their own websites. This is not permitted on VxON.
    Should you receive such a message, please report this using the 'Report' link you will find at the bottom of the message.
    Those users will then be dealt with accordingly.
  3. Use The Search Function That's what It is There For!
    The chances are that the post you are about to make has already been asked so USE the search function first! You can either search JUST this forum by clicking on the search button on the top right (under the page numbers) or click on the main search button that is on the top tool bar.
    This will save you time and stop the same duplicate posts from appearing.

[Zafira A] [99-05] Out of the blue - Fault code 0353, loss of power

Discussion in 'Astra, Corsa, Zafira, Meriva, Adam, Agila, Tigra & Nova [Includes AstraVan & ComboVan] owners forum' started by dnalevy, May 25, 2010.

  1. dnalevy

    dnalevy Active Member

    Messages:
    125
    Likes Received:
    0
    Location:
    London
    Hi
    I have a Zafira A 1999 1.8 16V petrol.
    Fully serviced about 2 months ago.
    Yesterday was driving along, came to a stop and the engine started to struggle to idle.
    Engine management light came on - giving 0353 which I believe is the following:

    P0353 Ignition Coil 3 High Input B-23
    P0353 Ignition Coil 3 Incorrect Signal B-23

    Since then on and off its driving in a reduced power limp mode and seems to be misfiring when in this state.

    Any ideas what it is and am i correct to assume its not a fuel line problem or sensor problem because only one cylinder is coming up with an error?

    Coil pack possibly? Or what else could it be? Plugs recently changed.

    Thanks for the help!
     
  2. Fire26662

    Fire26662 There can be only one.

    Messages:
    11,926
    Likes Received:
    838
    Location:
    Hereford
    Can you remind me if you have one long coil or 4 separate ones.
     
  3. marks152

    marks152 Well-Known Member

    Messages:
    9,689
    Likes Received:
    784
    Location:
    liverpool, uk
    its 1 long one
     
  4. Fire26662

    Fire26662 There can be only one.

    Messages:
    11,926
    Likes Received:
    838
    Location:
    Hereford
    darn, I think I have some test data here if you are ok with a multimeter, let me know.
     
  5. vectraowner

    vectraowner Active Member

    Messages:
    474
    Likes Received:
    1
    Location:
    Denmark
    Coil pack is a good starting point....If this does not help then possibly ECU..

    Vectraowner
     
  6. Fire26662

    Fire26662 There can be only one.

    Messages:
    11,926
    Likes Received:
    838
    Location:
    Hereford
    Also been thinking (got a headache now!) check number 3 plug hole, look for oil, also take the plug out too, look for tracking marks on the insulator and the rubber connector where it sits on the spark plug. The actual code says it is a primary/secondary resistance issue but... check the cheap things 1st.
     
  7. dnalevy

    dnalevy Active Member

    Messages:
    125
    Likes Received:
    0
    Location:
    London
    Yes its a 1 long coil unit as mentioned.
    Funny that its intermittent, sometimes running fine. Also doesnt seem to be connected to engine temp.
    I'm fine with a multimeter.
    Got a coil pack arriving tomorrow and also gonna check the plug itself.
    I'm hoping its not the ECU :eek:
     
  8. dnalevy

    dnalevy Active Member

    Messages:
    125
    Likes Received:
    0
    Location:
    London
    Changed the coilpack, seems to be all good now.... :)
     
  9. 12reedling

    12reedling New Member

    Messages:
    17
    Likes Received:
    0
    Location:
    sunderland
    i have the same problem on my y reg mk4 astra 1.4 16v i replaced my coil pack but same problem need help asap thanks
     
  10. Fire26662

    Fire26662 There can be only one.

    Messages:
    11,926
    Likes Received:
    838
    Location:
    Hereford
    You have the same fault code?
     

Share This Page