1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. It's been bought to our attention that certain users are spamming new and existing users with links to their own websites. This is not permitted on VxON.
    Should you receive such a message, please report this using the 'Report' link you will find at the bottom of the message.
    Those users will then be dealt with accordingly.
    Dismiss Notice
  3. Use The Search Function That's what It is There For!
    The chances are that the post you are about to make has already been asked so USE the search function first! You can either search JUST this forum by clicking on the search button on the top right (under the page numbers) or click on the main search button that is on the top tool bar.
    This will save you time and stop the same duplicate posts from appearing.
    Dismiss Notice

My Vectra Losing Power

Discussion in 'Cavalier, Calibra, Vectra, Signum, Sintra & Insignia owners forum' started by easygav, May 16, 2007.

  1. easygav

    easygav New Member

    Messages:
    11
    Likes Received:
    0
    Location:
    uk suffolk
    my vectra has recently been losing a little bit of power, well as you drive down the road you can feel it chugging ie pulling back. if you are in a high gear in any car and you are going say 30mph your car will like sound as though it will stall..

    simular with my car you can be going at any speed and every now and again it will feel like it shakes losing a bit of power.

    ive checked the oil its fine the water is fine..

    please can people tell me what else can cause this problem.. ive looked at the plugs and they all seem fine.
     
  2. greasemonkey

    greasemonkey VXon Frontera Monkey VxON Club Member

    Messages:
    9,874
    Likes Received:
    68
    Location:
    Bury St Edmunds Isuzu Land
    Drives:
    Frontera
    Hi have you cleaned the egr valve ?
    regards
    Steve
     
  3. easygav

    easygav New Member

    Messages:
    11
    Likes Received:
    0
    Location:
    uk suffolk
    EGR valve

    i must admit im not to good under the bonnet..

    where do i find EGR valve...

    sorry
     
  4. easygav

    easygav New Member

    Messages:
    11
    Likes Received:
    0
    Location:
    uk suffolk
    Urgent

    i have just noticed that my car holds back but only when you reach 1000-15000 revs... it doesnt do it after this...

    also my car has got a FSE power boost valve could this be the problem?
     
  5. Stevie G

    Stevie G Member

    Messages:
    15
    Likes Received:
    0
    Location:
    Staffs
    An FSE boost valve will have nothing to do with this problem as my misses has a 1.8 16v T reg vectra and it has been doing exactly the same thing, and it does not have an FSE valve.

    It has been juddering an awful lot over the past 2 days, only at lower rev rather than higher rev range and more so at a steady speed rather than 50mph +

    The breather pipe was replaced as it had got very soft and was worn with a hole in the side as i came accross oil leaking out onto the cam cover.
    The same problem with the hose getting too soft from the heat and wearing away witht he other breather pipe at the back of the block going to the throttle body, that was replaced near on 4 month ago.

    The problem still persists, i am however going to clear out the ICV and spray carb/injector cleaner through the pipes and throttle body etc and see if i can clear out any thick crud and gunk.

    I also am not aware on what the EGR valve is, so if someone could please help my explaining it would be greatly appreciated.

    I shall check back tomorrow to see if someone has replied and helped us out.

    Steve.
     
  6. Lorian

    Lorian New Member

    Messages:
    30
    Likes Received:
    0
    Location:
    Midlands
    I had a very similar problem after replacing the crankshaft breather hoses on my my 2,0SRi (X20XEV) a few weeks ago.

    It went away when I left the battery disconnected for an hour to reset the ECU. (make sure you have your radio code/car pass first!)

    Maybe the same will work for you, good luck.
     
  7. richardjohnson1982

    richardjohnson1982 New Member

    Messages:
    60
    Likes Received:
    1
    Location:
    Birmingham
    What engine and year?
     
    voxvect likes this.
  8. Dillmiester

    Dillmiester New Member

    Messages:
    137
    Likes Received:
    7
    Location:
    Leicester
    I would also be interested in how to clean the egr valve on a 2L DTI
    cheers
     
  9. richardjohnson1982

    richardjohnson1982 New Member

    Messages:
    60
    Likes Received:
    1
    Location:
    Birmingham
    A lot of the comments above are regarding petrol engines,
    The EGR could be a cause but unlikly,
    Check for vacume leaks on the compleat air intake track including all off pipes ( T's and elbows )
    Check the vacume pump as seen a few of these fail, make sure it holds a vacume
    Do overhaul of inlet system and you have a good chance to find it gummed up
    Are you sure it is not just turbo lag,
     
  10. Dillmiester

    Dillmiester New Member

    Messages:
    137
    Likes Received:
    7
    Location:
    Leicester
    Ive finally taken the plunge and took off the EGR valve and it was very coked up (never seen so much of the stuff).
    When cleaned and put back togther and running I noticed the soleniod connected to it by a pipe is making a buzzing sound. Is this because its in shock that its working with a helthy EGR or have I woken a problem?
     

Share This Page