1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. It's been bought to our attention that certain users are spamming new and existing users with links to their own websites. This is not permitted on VxON.
    Should you receive such a message, please report this using the 'Report' link you will find at the bottom of the message.
    Those users will then be dealt with accordingly.
  3. Use The Search Function That's what It is There For!
    The chances are that the post you are about to make has already been asked so USE the search function first! You can either search JUST this forum by clicking on the search button on the top right (under the page numbers) or click on the main search button that is on the top tool bar.
    This will save you time and stop the same duplicate posts from appearing.

  1. 1.7CDTi

    1.7CDTi New Member

    Messages:
    17
    Likes Received:
    0
    Location:
    UK
    Hi,

    The wife has a 2005 (55 plate) Zafira (B) 1.9 CDTi 150, lovely car but its been nothing but trouble since 3 months after we got it.

    I now have bought a OP-COM 2009 cable and software to find the problem with the car as the orange triangle with a car skidding into it has been on for a couple of weeks and my PPE interface cable must only read Engine codes.

    Car still drives perfect, steers great, ABS works but the traction control doesn't.

    OK so I was rather shocked at the number of fault codes this car had, where shall I start.

    DIS ECU

    1. U2139-71 Invalid Data from CIM
    2. U2140-71 Invalid Data from UEC

    IPC ECU

    1. U2117-00 CAN BUS No Communications with DIS
    2. U2100-00 No Communications with CAN BUS (High Speed)

    CIM ECU

    1. U2100-00 No Communications with CAN BUS (High Speed)
    2. U2117-00 CAN BUS No Communications with DIS
    3. U2100-0F No Communications with DIS (Low Speed) (Was Gained After stopping engine and switching ignition back on)

    ABS/TC/ESP ECU

    1. U3000-00 Unknown DTC
    2. C0131-00 Pressure Sensor Curcuit Malfunction (In RED)

    REC ECU

    1. U2100-00 No Communications with CAN BUS (High Speed)

    Immobilizer

    1. U2100-0F No Communications with DIS (Low Speed)
    2. U2117-00 CAN BUS No Communications with DIS

    Engine

    1. P0070-71 Ambient Air Temperature Sensor Malfunction
    2. P0650-70 Malfunction Indicator Lamp (MIL) Control

    I did notice that the whole dash went blank when I was trying to connect to the EPS (Electronic Power Steering) ECU but my car must not have one, I thought it would have. This may have caused the Engine error codes. As soon as I connected to the EHPS the dash lit up again.

    I also noted the dip beam came on as it should when I did an output test (Its all new to me, controlling car features with a lap top lol) but wouldn't go off when de-activated until I reconnecting to another ECU? Maybe normal??

    Anyway, the last four weren't there when I started and where cleared to never come back by the time I had finished so I'm guessing I probably caused them with mucking about testing curtain things.

    So really I have 7 codes & one that I think is bringing the light on C0131-00

    1. U2139-71 Invalid Data from CIM
    2. U2140-71 Invalid Data from UEC
    3. U2117-00 CAN BUS No Communications with DIS
    4. U2100-00 No Communications with CAN BUS (High Speed)
    5. U2100-0F No Communications with DIS (Low Speed)
    6. U3000-00 Unknown DTC
    7. C0131-00 Pressure Sensor Curcuit Malfunction

    8. P0070-71 Ambient Air Temperature Sensor Malfunction (Cleared)
    9. P0650-70 Malfunction Indicator Lamp (MIL) Control (Cleared)


    I'm a little concerned about all the fault codes but mainly need to know what the C0131-00 is and what I need to do to fix it. I only found one result which was a guy listing error codes next to stuff he was selling saying "buy this and get rid of your error code" but I hope I dont need to change the whole ABS unit as I hate bake fluid.

    Any help appreciated

    Cheers.
     
  2. sieski

    sieski New Member

    Messages:
    89
    Likes Received:
    0
    Location:
    west midlands
    I would say some of these codes are actualy caused by the original fault. So I wouldn't worry too much at the moment. You need to clear the C0131-00 as I believe like you thats the major fault.

    abs pump came up in a search and a few articles on the code on mototek.technical-articles.co.uk but you have to be a member to see the full soloution.

    Good luck anyway!
     
  3. 1.7CDTi

    1.7CDTi New Member

    Messages:
    17
    Likes Received:
    0
    Location:
    UK
    Thanks for the advice, I must have turn off the notification of reply by acident hence the long time until I replied.

    Still have the code on the ECU but the car behaves fine or it appears to, accept the lack of traction control.

    I'll check out the link if I can.

    Thanks again.
     

Share This Page