1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. It's been bought to our attention that certain users are spamming new and existing users with links to their own websites. This is not permitted on VxON.
    Should you receive such a message, please report this using the 'Report' link you will find at the bottom of the message.
    Those users will then be dealt with accordingly.
  3. Use The Search Function That's what It is There For!
    The chances are that the post you are about to make has already been asked so USE the search function first! You can either search JUST this forum by clicking on the search button on the top right (under the page numbers) or click on the main search button that is on the top tool bar.
    This will save you time and stop the same duplicate posts from appearing.

  1. RobinsFan

    RobinsFan New Member

    Messages:
    11
    Likes Received:
    0
    Location:
    Hull, East Yorks
    Hi All,
    I've just recently taken off my egr valve to clean, there's quite a bit of carbon on the piston so I've used a tooth brush and carb cleaner to get rid of all the gunk...but I was wondering if the piston im cleaning is supposed to move when I push on it cos mine is just flush with the bottom ov the cylinder and doesnt move at all, thus me thinking it maybe stuck....my car is currently misfiring and has had a 2nd hand coil pack and new ngk plugs fitted..any advice is appreciated, cheers Jim (y)
     
  2. marks152

    marks152 Well-Known Member

    Messages:
    9,691
    Likes Received:
    784
    Location:
    liverpool, uk
    it will not move when you push it, if its flush then its in the closed position, if you apply 12v to the outer 2 pins it will open,
     
  3. RobinsFan

    RobinsFan New Member

    Messages:
    11
    Likes Received:
    0
    Location:
    Hull, East Yorks
    ah cheers, I did think it may need a current, will it need a clean out whilst in the on position then too ?
     
  4. RatCav

    RatCav Well-Known Member

    Messages:
    2,827
    Likes Received:
    21
    Location:
    Norwich
    Drives:
    Lotus Trooper/Nissan 300ZX/Frontera 2.3TD
    The piston should push in on the 1.6 EGR. Sits flush when shut ... draws in to open it.
     
  5. marks152

    marks152 Well-Known Member

    Messages:
    9,691
    Likes Received:
    784
    Location:
    liverpool, uk
    Thats incorrect, ive got a spare one infront of me and when 12v is applied to the outer 2 pins it extends/opens, when the power is removed it snaps shut flush with the housing,

    You can only open it by either activating it with opcom or tech2 or manually giving the 2 outer pins 12v when the main plugs disconnected
     
  6. RobinsFan

    RobinsFan New Member

    Messages:
    11
    Likes Received:
    0
    Location:
    Hull, East Yorks
    Might just look for a new one on ebay if it persists...hmmmm
     
  7. marks152

    marks152 Well-Known Member

    Messages:
    9,691
    Likes Received:
    784
    Location:
    liverpool, uk
    This would be the best way forward, cleaning often doesnt work
     
  8. RobinsFan

    RobinsFan New Member

    Messages:
    11
    Likes Received:
    0
    Location:
    Hull, East Yorks
  9. RatCav

    RatCav Well-Known Member

    Messages:
    2,827
    Likes Received:
    21
    Location:
    Norwich
    Drives:
    Lotus Trooper/Nissan 300ZX/Frontera 2.3TD
    Lol ... live and learn. I thought they were the same as the 1.4. :D
     
  10. marks152

    marks152 Well-Known Member

    Messages:
    9,691
    Likes Received:
    784
    Location:
    liverpool, uk
    They are i think, but mine definetely moves out when activated, According to that ebay listing they are the same on 1.4,1.6 and 1.8
     

Share This Page